You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
29 lines
642 B
29 lines
642 B
{ lib, config, ... }:
|
|
{
|
|
services.gitea = {
|
|
enable = true;
|
|
rootUrl = "https://git.gurkan.in";
|
|
appName = "My git forks";
|
|
httpAddress = "127.0.0.1";
|
|
domain = "git.gurkan.in";
|
|
settings = {
|
|
service.DISABLE_REGISTRATION = true;
|
|
log.LEVEL= "Warn";
|
|
repository = {
|
|
DEFAULT_REPO_UNITS = "repo.code,repo.releases";
|
|
};
|
|
server = {
|
|
LANDING_PAGE = "explore";
|
|
};
|
|
ui = {
|
|
SHOW_USER_EMAIL = false;
|
|
};
|
|
"ui.meta" = {
|
|
DESCRIPTION = "This is where I fork my stuff";
|
|
};
|
|
other = {
|
|
SHOW_FOOTER_VERSION = false;
|
|
};
|
|
};
|
|
};
|
|
}
|
|
|